DDoS Attack In-Progress
Incident Report for Maikiwi Global Network
Resolved
This incident has been resolved.
Posted Aug 15, 2021 - 14:51 PDT
Monitoring
It seems that the attack had already stopped (or the malicious packets have been filtered on edge locations by our ISP), so we're continuing to monitor the target service of the attack for a day or two before declaring this incident resolved. If you still somehow got affected by this event, please email us or shoot a message on telegram.
Posted Aug 12, 2021 - 14:40 PDT
Update
Just a small update after 12 hours from the management.

The attack is still ongoing though most of the already filtered IPs have been put into our blacklist for 14 days.
This wasn't enough to trigger our fallback routing, but it did raise some eyebrows in our Security Operations Team as it seemed to target one specific service that one of our clients was running.

All in all, report to us as soon as possible if your service is getting affected by this attack.
We appreciate all of you for being our loyal customers @ MGN.

Best,
Tao L. - Infrastructure Ops.
Posted Aug 11, 2021 - 16:08 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 11, 2021 - 03:52 PDT
Identified
Welp, we've been hit with a sizable ~44Mpps SYN on our Eastern Front, and our mitigation system is currently in the process of actively filtering the traffic. Don't worry; this will only slow some of the good packets down by a few milliseconds. If you see your service getting interrupted, it most likely means that our system has incorrectly dropped your visitor's traffic. Shoot us an email or message on telegram if you are affected by this, and we will be more than happy to sort this out for ya.
Posted Aug 11, 2021 - 03:51 PDT
This incident affected: Incoming Packet Handler and Global Network (China, Australia).