Infrastructure Migration
Incident Report for Maikiwi Global Network
Resolved
Our newly built cloud infrastructure in China has passed all of our internal auditing checks and attack simulations.
All affected clients are issued account credit for compensation for the duration of the stress test.

(Somehow that also broke our Static Image Service which has been repaired just this morning)
Posted Aug 01, 2021 - 16:21 PDT
Monitoring
An internal stress test is in progress targeting all of the new MGN locations in China.

Our main IPH might experience partial performance degradation due to sustained stress.
Currently peaking at ~1.2Tbps and no slowdowns.

In the case where the IPH can't keep the filtering up to speed with the attack, it automatically routes to AWS Shield to keep our client's services unaffected. (So far, it hasn't triggered the fallback mechanism)

Please rest assured that if you see your network metrics freaking out, you will automatically issue account credits once the stress test is over.

We plan to keep stressing our network for about 5-6 more hours. More updates will be coming soon!
Posted Jul 31, 2021 - 22:33 PDT
Identified
Hebei, China, is currently ongoing a scheduled migration.
All data located in Hebei, China, stored by MGN will retain for 14 days starting from now in Object Storage before termination.

MGN in China is getting a long-needed expansion.
The addition consists of:
- Beijing, China (Aliyun Dedicated)
- Jiangsu, China (China Telecom)
- Quanzhou, China (China Unicom)
- Anhui, China (China Telecom)
- Shanghai, China (Aliyun Dedicated)
- Zhejiang, China (Aliyun Shared)

Existing clients will receive an email containing the necessary info for you to migrate without downtime seamlessly.
Yearly IaaS Customers will not be billed for the usage of our newly China locations for the week of 8/2 to 8/8.

Check the following map for details:
https://www.google.com/maps/d/viewer?mid=1MyqLRG01bw2Oh3RiNGHLBG-zKv-YG7ze
Posted Jul 30, 2021 - 18:37 PDT
This incident affected: Incoming Packet Handler and Static Image Service.